Excel: Verschachtelte Bedingungen – vereinfacht

Nicht nur in Excel wird vielfach verschachtelt. Foto: Adobe Stock / Jaroon Ittiwannapong
Nicht nur in Excel wird vielfach verschachtelt. Foto: Adobe Stock / Jaroon Ittiwannapong

Mit der Version Excel 2019/365 ist es sehr viel einfacher geworden, verschachtelte Bedingungen zu formulieren. Wo früher noch mehrfach verschachtelte WENN-Funktionen nötig waren, genügt es heute in vielen Fällen, die neue Funktion WENNS zu verwenden. Eine echte Erleichterung, wenn zum Beispiel verschiedene Grenzen nacheinander geprüft werden sollen.

Im folgenden Beispiel sollen Kunden nach ihrem Umsatz kategorisiert werden.

Die Kategorien bestimmen sich wie folgt:

bis 2.000              => D

bis 5.000              => C

bis 8.000              => B

darüber                 => A

Früher wäre hier eine verschachtelte WENN-Funktion nötig gewesen:

=WENN(B2<=2000;”D”;WENN(B2<=5000;”C”;WENN(B2<=8000;”B”;”A”)))

Mit der seit 2019 neuen Funktion WENN geht es viel einfacher und alle Grenzen werden in EINE Funktion eingetragen:

=WENNS(B2<=2000;”D”;B2<=5000;”C”;B2<=8000;”B”;WAHR;”A”)

Die Erklärung liest sich einfacher, wenn man den Funktions-Assistenten anschaut:

Alte Variante:

Excel - Verschachtelte Bedingungen

Neue Variante:

Excel - Verschachtelte Bedingungen

Wo man früher in einer “normalen” WENN-Funktion im “Wert_wenn_falsch” erneut eine WENN-Funktion hineinverschachteln musste, kann man bei WENNS direkt mit der nächsten Prüfung beginnen. Es werden immer im Wechsel jeweils zunächst die Bedingung angegeben, die erfüllt sein muss, und danach der Ergebniswert, der sich daraus ergibt. Die Bedingungen werden in der Abfolge geprüft, in der sie in der Formel stehen.

Kleine Besonderheit:

Um eine letzte “Restgröße” aufzufangen (in unserem Beispiel die Top-Kategorie “A”), muss auch hierfür eine “Pseudo-Prüfung” eingetragen werden, die immer erfüllt ist, um keine Fehlerwerte zu erhalten. Daher steht in der obigen Formel als vorletztes Argument ein einfaches, von Hand eingetragenes WAHR, bevor die Kategorie “A” eingetragen ist.

Möchten Sie mehr über Funktionen in Excel wissen, empfehlen wir Ihnen unser Seminar Excel – Formeln und Funktionen. Wir freuen uns auf Sie!

Artikel drucken