Excel: Duplikate anzeigen und ausfiltern

Manchmal sind sie sinnvoll, oft sind sie aber unerwünscht und müssen entfernt werden: doppelte Daten in Excel-Tabellen. Wie findet man Duplikate in einem Arbeitsblatt? Wie kann man sie anzeigen lassen und wie filtert man danach? Wie kann man Duplikate gezielt ermitteln? Anhand eines Beispiels geben wir Ihnen dazu  Anregungen.

Excel - Duplikate

In dieser Tabelle kommen zwei Kundennummern mehrfach vor. Diese Mehrfacheinträge stammen aus mehreren Bestellungen und haben jeweils unterschiedliche Bestellnummern und Bestellwerte. Zwei Datensätze sind allerdings identisch, wenn man die laufende Nummer aus Spalte A außer Acht lässt, die beim Datenexport aus einem anderen System erzeugt wurde.

Doppelte Kundennummern farblich hervorheben und ausfiltern

Dafür markieren Sie alle Kundennummern in der Spalte B und verwenden eine bedingte Formatierung, die Sie im Register „Start“ finden:

Excel - Duplikate

Auf diese Weise sind die farblichen Markierungen in der Tabelle entstanden. Nach diesen Farben können Sie jetzt filtern. Aktivieren Sie dazu die Filter auf dem Register „Daten“. Im Filter der Kundennummer (Kd-Nr.) wählen Sie den Eintrag „Nach Zellenfarbe filtern“ und dann die entsprechende Farbe, die Sie den Duplikaten zuvor gegeben haben.

Excel - Duplikate

Übrig bleibt eine Liste aller Duplikate, die Sie am besten nach der Kundennummer sortieren. Jetzt können Sie die Datensätze vergleichen, bearbeiten oder löschen.

Nur den neuesten Datensatz zu jeder Kundennummer erhalten

Wollen Sie zu jeder Kundennummer nur den Datensatz der neuesten Bestellung erhalten, gehen Sie so vor:

  1. Sortieren Sie die Liste zunächst nach der Kundennummer aufsteigend und dann nach dem Bestelldatum absteigend. So stehen alle Datensätze zur gleichen Kundennummer beieinander, wobei der Neueste jeweils oben steht.
  2. Über den Menüpunkt „Duplikate entfernen“ auf dem Register „Daten“ können Sie alle doppelten Einträge mit der gleichen Kundennummer entfernen. Dazu setzen Sie einfach im Dialogfenster einen Haken bei der Kd-Nr.

Excel - Duplikate

Entscheidend ist die vorher durchgeführte Sortierung, denn der Menüpunkt „Duplikate entfernen“ behält jeweils den ersten Eintrag der Duplikate und entfernt alle darunterliegenden.

Formelauswertung: Wie oft gibt es eine Kundennummer?

In Spalte G der Tabelle wurde über die Funktion

=ZÄHLENWENNS($B$2:$B$22;B2)

ermittelt, wie oft jede Kundennummer in Spalte B vorkommt.

Excel - Duplikate

Aus dieser Anzahl errechnet sich in Spalte H, ob es sich um ein Duplikat handelt. In die Zelle H2 wurde dazu die Formel

=WENN(G2>1;“JA“;““)

eingegeben und nach unten kopiert.

Echte Duplikate per Formel herausfinden

Auch echte Duplikate, bei denen alle Einträge der Spalten B:E identisch sind, lassen sich per Formel ermitteln (die laufende Nummer wird dabei nicht berücksichtigt). Dazu setzen Sie in Zelle I2 die Funktion WENN ein, um den Text „JA“ (oder eine andere Kennzeichnung) ausgeben zu lassen (siehe Tabelle unten). Vier Bedingungen sind mit einem logischen UND verknüpft. Jede einzelne Bedingung überprüft eine andere Spalte auf Duplikate hin (wie oben gezeigt).

Anhand der Farben und der eingerückten Darstellung in der Bearbeitungszeile läßt sich die Logik der Bedingungen und deren Kombination gut nachvollziehen:

Excel - Duplikate

Sämtliche Berechnungen in den Spalten G:I bieten ebenso die Grundlage für Ausfilterungen und Sortierungen.

Weitere Anleitungen und Tipps zum Arbeiten mit Excel erhalten Sie in unseren Excel-Seminaren, zu denen wir Sie herzlich einladen.

(Beitragsbild: Pedro Figueras, pexels.com)

Artikel drucken