Excel: Dynamische Punktdiagramme

Möchten Sie in Excel einzelne Werte in einem Punktdiagramm dynamisch hervorheben, bieten sich Pfeile als Markierungen an. Die Kombination von Formeln mit einer Datenreihe ermöglicht es Ihnen, durch bloßes Ankreuzen zusätzliche Pfeilmarkierungen in einem Punktdiagramm anzuzeigen. Sogar die Optik der Pfeile können Sie sehr einfach durch Eingaben im Tabellenblatt ändern.

So funktioniert es:

Excel-Diagramme: Dynamische Pfeilmarkierungen im Punktdiagramm

Erzeugen des Grunddiagramms

Die blaue Tabelle enthält einige XY-Daten, die in diesem Beispiel Messpunkte darstellen. Aus diesen Werten wird ein einfaches Punktdiagramm ohne Verbindungslinien erzeugt.
In dem Beispiel sind die Datenpunkte in Größe 10 mit roter Markierungsfüllung und einer schwarzen Markierungslinie sowie einem Leuchteffekt formatiert.

Excel-Diagramme: Dynamische Pfeilmarkierungen im Punktdiagramm

Datenreihe für die grünen Pfeile erzeugen

Sämtliche Pfeile sind Bestandteil einer einzigen Datenreihe. Diese werden in der grünen Tabelle in Spalte D erzeugt. Dort werden aus den Y-Koordinaten der blauen Tabelle und den Angaben für Pfeilabstand und Pfeillänge die Y-Koordinaten des jeweiligen Pfeilanfangs und -endes errechnet. Die zugrunde liegenden Formeln finden Sie weiter unten.

Als neue Datenreihe werden die Zellen D18:D46 in das Diagramm aufgenommen.

Excel-Diagramme: Dynamische Pfeilmarkierungen im Punktdiagramm

Um die Pfeiloptik zu erzeugen, wird die Datenreihe mit einer grünen, durchgezogenen Linie (Breite: 4pt) und einem Pfeil als Endtyp für die Linie formatiert.

Excel-Diagramme: Dynamische Pfeilmarkierungen im Punktdiagramm

Jeder Pfeil besteht aus einem Anfangs- und einem Endpunkt mit gleicher X-Koordinate, die durch Linien miteinander verbunden sind. Die grauen Balken der Tabelle, mit leeren Zellen, sorgen dafür, dass die Datenreihe nach jedem Pfeil unterbrochen ist. Standardmäßig werden solche Unterbrechungen in einem Punktdiagramm als Lücken gezeichnet.

Hier zum besseren Verständnis die Optik des Diagramms, wenn man unter
DiagrammtoolsEntwurfDaten auswählenAusgeblendete und leere Zellen
statt der Lücken Verbindungslinien anzeigen lässt:

Excel-Diagramme: Dynamische Pfeilmarkierungen im Punktdiagramm

Die Berechnungen der Tabelle

Zum Schluss noch die Formeln und Werte, die zum Aufbau der grünen Tabelle benötigen werden:

A18: 1
A19: =A18
B18: =WENN(BEREICH.VERSCHIEBEN(B$1;$A18;0)<>““;BEREICH.VERSCHIEBEN(B$1;$A18;0);#NV)
Füllen Sie den Bereich B18:C19 mit dieser Formel aus.

D18: =WENN(C18=“x“;B18+D$14+D$15;#NV)
D19: =WENN(C18=“x“;B18+D$14;#NV)

Markieren Sie den Bereich A18:D20 und füllen Sie die Tabelle bis in die Zeile 46 aus.

Mehr Tipps?
Dann abonnieren Sie unseren kostenlosen Newsletter. Darin finden Sie Tipps zum Arbeiten mit Office, Hilfen bei der Gestaltung von Werbemitteln und Hinweise  auf nützliche Tools. Der Newsletter erscheint einmal im Monat. Hier geht’s zur Anmeldung.

Weitere Tipps und solides Grundlagenwissen zur Gestaltung ansprechender Excel-Diagramme erhalten Sie in unserem Seminar Diagramme mit Microsoft Excel. Wir freuen uns auf Sie.

Artikel drucken