Excel: Lernkartensystem selbst gestalten

Lernkarten mit Excel. Foto: pixels.com

Egal ob Sie eine Sprache lernen oder eine Weiterbildung machen: Lernkarten sind immer eine große Hilfe. Es gibt zahllose Programme und Apps, mit den Lernkarten erstellt werden können. Man kann aber auch in Excel ein Lernkartensystem gestalten. Das geht ganz einfach mit der Funktion WENN und dem Autofilter.

Das Lernkartensystem aufbauen

Als Beispiel nehmen wir mal an, wir wollen folgende Fragen üben:

Lernkarten mit Excel

Da wir die Antworten nicht lesen möchten, blenden wir Spalte C aus. Wir markieren dazu diese Spalte, klicken mit der rechten Maustaste und wählen im Kontextmenü „Ausblenden“ aus.

Lernkarten mit Excel

Anschließend muss eine neue Spalte für die Antworten eingerichtet werden, worin jede Antwort auf Wunsch gezeigt werden kann. Wir geben dazu in Zelle D1 den Text “Antwort” ein, und in Zelle E1 “Antwort zeigen?”. Dann geht in Zelle D2 folgende Formel:

=WENN(E2=“x“;C2;““).

Wir klicken Zelle D2 noch mal an und gehen mit dem Mauszeiger auf das kleine Quadrat rechts unten bei dieser Zelle. Es erscheint ein kleines, schwarzes Pluszeichen. Das ziehen wir bis in Zelle D8 herunter, damit die Formel in die Zellen D3 bis D8 hineinkopiert wird.

Lernkarten mit Excel

Das Lernkartensystem ist bereit. Sie können in Spalte E ein x eingeben, wenn Sie eine Antwort sehen wollen, und das x wieder löschen, um die Antwort verschwinden zu lassen. Testen Sie es!

Die Lernkarten filtern

Das System soll aber etwas flexibler werden. Man will ja auch mal die falsch beantworteten Fragen wiederholen können, oder ein bestimmtes Thema studieren.

Dazu werden wir die Spalten F und G einrichten und den Autofilter einschalten. Geben Sie in Zelle F1 den Text „richtig?“ ein und in einige Zellen zwischen F2 und F8 ein x. Geben Sie Spalte G die Überschrift „Thema“ und ordnen Sie jede Frage einem Thema zu. Schalten Sie den  Autofilter über die Schaltfläche „Filtern“ im Register „Daten“ ein.

Lernkarten mit Excel

In jeder Spalte erscheint ein Filterpfeil. Wenn Sie die falsch beantworteten Fragen wiederholen möchten, aktivieren Sie in der Filter-Auswahlliste für Spalte F nur das Kontrollkästchen vor „Leere“.

In Spalte G können Sie ein oder mehrere Themen auswählen. Sie werden dann nur noch die Fragen sehen, die zu Ihrer Auswahl passen.

Lernkarten mit Excel

Im Register „Daten“, in der Gruppe „Sortieren und Filtern“ gibt es eine Schaltfläche “Löschen”. Damit entfernen Sie die Filter und machen Sie alle Fragen wieder sichtbar.

Lernkarten hinzufügen oder ändern

Die Antworten in Spalte C können über das Kontextmenü wieder eingeblendet werden. Sie müssen dazu die Spalten B und D markieren. Vergessen Sie beim Hinzufügen von neuen Fragen nicht, die Formeln in Spalte D weiter herunter zu kopieren. Viel Erfolg beim Lernen!

Quelle der Fragen: www.raetselstunde.de

Weitere Tipps zu Excel erhalten Sie unseren Excel-Seminaren. Wir freuen uns auf Sie!

Artikel drucken